This service is archived, please use www.eclipse.org/forums


Home » Capella » General information » Addon Requirements v0.5.0 (beta) has been released for evaluation
Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1248] Tue, 07 February 2017 10:37 Go to next message
philippe.dul is currently offline  philippe.dul
Messages: 49
Registered: April 2015
Member
Addon Requirements v0.5.0 (beta) has been released for evaluation

The Requirements Viewpoint for Capella allows importing a set of requirements from a ReqIF file.

You can download this beta version on Capella website following this link.

Compatibility: Capella v1.1.1 (capella 1.1.1 evaluation version can be downloaded here

index.php/fa/352/0/
index.php/fa/351/0/
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1280 is a reply to message #1248] Fri, 10 February 2017 10:33 Go to previous messageGo to next message
Aurélien Pinsonneau is currently offline  Aurélien Pinsonneau
Messages: 169
Registered: November 2016
Senior Member
Hello,

Thanks for this addon!

Is there a short user guide available??
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1283 is a reply to message #1280] Fri, 10 February 2017 11:01 Go to previous messageGo to next message
philippe.dul is currently offline  philippe.dul
Messages: 49
Registered: April 2015
Member
Hi Aurélien,

Indeed there is an user guide.

When installed, just go to the Help Menu > Help Contents > Requirements Viewpoint.


To install the viewpoint, you can download the dropins version and unzip it into the dropins folder of Capella v1.1.1, then the user guide will be available within Capella.

Regards,
Philippe
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1316 is a reply to message #1283] Thu, 09 March 2017 16:09 Go to previous messageGo to next message
Richard C. is currently offline  Richard C.
Messages: 104
Registered: December 2016
Senior Member
Hello,

I have tried to import some ReqIf-Data with the Req-Addon. After the import I can only see a "tree structure" of my requirements but no requirements at all. Is the AddOn already functional? Is there anything else to be considered at the import?

Is there anywhere a working test-ReqIf-file?

Kind regards
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1319 is a reply to message #1316] Fri, 10 March 2017 08:58 Go to previous messageGo to next message
Christophe Gatti is currently offline  Christophe Gatti
Messages: 147
Registered: September 2014
Location: Paris, France
Senior Member

Hi,
Could you please describe your environment and be sure to use Capella 1.1.1 as mentioned as the top of the topic?
Is it possible for you to share your requirement file? We'll attempt to reproduce the problem then.
We are setting up example files so once available we will communicate. Keep in mind that the Requirement Viewpoint is in beta stage and Capella 1.1.1 not officially released.
Regards,
Christophe
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1321 is a reply to message #1248] Mon, 13 March 2017 05:40 Go to previous messageGo to next message
jerome.montigny.continent is currently offline  jerome.montigny.continent
Messages: 18
Registered: February 2015
Junior Member
Hello,

I have exactly the same issue than Richard.
Environment: Capella 1.1.1 downloaded via the above link in this post.
Default configuration in Capella Importer preferences
ReqIF file generated with Doors 9.6.1.3 (see attachment)
The ReqIF file is good (check with ReqIF Studio application)
Result: (see picture) only the ReqIf.chapterName are imported, not the ReqIf.Text or either standard ReqIf attibutes present in the ReqIf file and declared in the Eclipse preferences.

index.php/fa/367/0/
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1332 is a reply to message #1321] Thu, 16 March 2017 16:27 Go to previous messageGo to next message
Christophe Gatti is currently offline  Christophe Gatti
Messages: 147
Registered: September 2014
Location: Paris, France
Senior Member

Hi,

Sorry for the delayed answer. It seems that in your REQ-IF file, the attribute IE PUID is missing from your requirements.
Our use case consists in exporting requirements from Doors database enriched with the RMF add-on that produces this attribute.
The viewpoint parses this attribute to now if the requirement is considered as "valid".
We plan to remove this constraint so that this attribute will not be mandatory anymore.
Sorry for the limitation, this is currently a prototype so thanks for the feedback! I'll try to attach a "correct" REQ-IF file so that you could modify yours according to it.

Best regards,
Christophe
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1336 is a reply to message #1332] Fri, 17 March 2017 04:15 Go to previous messageGo to next message
jerome.montigny.continent is currently offline  jerome.montigny.continent
Messages: 18
Registered: February 2015
Junior Member
Indeed, we are using the standard ReqIf export of Doors.
Do you plan to have this change available in the next 1.1.1 release of Capella?
Thx
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1349 is a reply to message #1336] Mon, 27 March 2017 10:36 Go to previous messageGo to next message
steve.coombs.asarosystems is currently offline  steve.coombs.asarosystems
Messages: 1
Registered: March 2017
Junior Member
I am just enquiring if a solution was found to the DOORS ReqIF import not bringing in the requirement items?
I have a ReqIF file generated by DOORS with the IE PUID attribute created by the RMF and these do not seem to be imported.

I am running Capella 1.1.1. I am familiar with ReqIF so any help with the import would be appreciated, or if you have a sample ReqIF I can use to ensure mine is similar.

Thx.
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1362 is a reply to message #1349] Tue, 11 April 2017 07:20 Go to previous messageGo to next message
grdevda.gmail.com is currently offline  grdevda.gmail.com
Messages: 6
Registered: April 2017
Junior Member
Is it possible for you to share your .reqif file to run the test on our side.

info: hope you follow the merge step as mentioned in the embedded doc.
see the attached image

Regards,
Shyam DEVDA
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1400 is a reply to message #1362] Tue, 09 May 2017 08:18 Go to previous messageGo to next message
kilian.stevens.lgm.fr is currently offline  kilian.stevens.lgm.fr
Messages: 11
Registered: May 2017
Junior Member
Good Afternoon everyone,

I am currently working on a project with Capella and I have several questions for you:

First of all,

*I would like to know what is the difference between a ReqIf file and a Reqif file transformed into a .xml file

* What is the version of DOORS do you have?
I have version 9.3 and when I want to export a Requirements file, it's a .xml file..

* But anyway, Do you think it's possible to import a .xml file on Capella as a .reqif file?

and for the last one,
*Do you think it's possible to have a reqif file template to try the import on my Capella project to continue it ?


Thanks for your help.
Regards.


(FYI, I have version Capella 1.1.1).

Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1501 is a reply to message #1400] Wed, 26 July 2017 11:04 Go to previous messageGo to next message
Benoit VIAUD is currently offline  Benoit VIAUD
Messages: 16
Registered: February 2016
Junior Member
Hello,

I can't find a reqif file that uses the IE PUID as mentionned above.
Can anyone provide a sample file here so that we could do some testing of the viewpoint in Capella?

Best regards,
Benoit
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1502 is a reply to message #1501] Wed, 26 July 2017 11:20 Go to previous messageGo to next message
Christophe Gatti is currently offline  Christophe Gatti
Messages: 147
Registered: September 2014
Location: Paris, France
Senior Member

Hi,
For information, we released a first beta version of the viewpoint that supports the import of requirements without the IE PUID attribute.
You can try this beta version following this link.

@Benoit: Sorry, our Doors database contains sensible data thus we cannot make them available. Have you tried with the REQ-IF files attached to this thread?
@Kilian: I don't know precisely the Doors version we use, but I think you have a menu "File -> Export" that enables you to export your requirements as REQ-IF standard format output file. A file with .reqif extension is needed to be parsed by the viewpoint. Note: a REQ-IF file is an XML file format that can be used to exchange requirements. Could you open your output xml file with a text editor? If the root element is REQ-IF then try to rename it with .reqif extension and try to import it into Capella. Last but not least, you could find sample REQ-IF files in this thread for download.

Regards,

Christophe

[Updated on: Wed, 26 July 2017 11:21]

Report message to a moderator

Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1505 is a reply to message #1502] Thu, 27 July 2017 07:23 Go to previous messageGo to next message
Benoit VIAUD is currently offline  Benoit VIAUD
Messages: 16
Registered: February 2016
Junior Member
This version does work with the sample provided by Jerome above in this thread.

Many thanks
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1741 is a reply to message #1505] Thu, 07 December 2017 05:05 Go to previous messageGo to next message
manunggal.s.gmail.com is currently offline  manunggal.s.gmail.com
Messages: 2
Registered: November 2017
Junior Member
Hi, I am new with Capella. I am evaluating Capella for my company's future project.
I have created reqif document with Eclipse Pror, can I export it to Capella?
Is there any tutorial or example somewhere explaining how to manage reqif file and how to allocate the specobject for each physical component within Capella? Merci.
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #1742 is a reply to message #1741] Thu, 07 December 2017 05:16 Go to previous messageGo to next message
Michel BISPO is currently offline  Michel BISPO
Messages: 33
Registered: February 2015
Member
Hi,

when installing this addon, you will have an Eclipse embedded documentation with lot of information.

We are preparing a next version 0.9.0 for the next major release of Capella 1.2, for the end of the year.
In this next version, we have enhance this documentation and fix some important issues to better manage reqif iterative re-import (Capella / dropins nightly builds are available for evaluation).

Best regards,

Michel

[Updated on: Thu, 07 December 2017 05:17]

Report message to a moderator

Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #2488 is a reply to message #1742] Tue, 23 October 2018 13:20 Go to previous messageGo to next message
moe.sadri is currently offline  moe.sadri
Messages: 7
Registered: July 2017
Junior Member
Hello,

In Capella integrated help, Requirements Viewpoint/Getting Started/ the following is noted:
"Capella provides also Legacy Capella requirements (Right click, Add Element "Requirement Package"), but there is no relation with this advanced Requirement Viewpoint. For a next Major Release to plan, these Legacy Requirements will be removed from Capella and migrated to this new Viewpoint requirements through a dedicated migration tooling and, then, no more available within Capella core."

Can you please update us on the latest approach to capture requirements in Capella? Using the option of Add Capella Element/Requirements Package/ is not advised in developing new models? I am planning to develop a model on Capella 1.2.1 and wanted to know the most current practice.

Thank you,
Moe
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #2490 is a reply to message #2488] Wed, 24 October 2018 11:19 Go to previous messageGo to next message
stephane.lacrampe.obeo.fr is currently offline  stephane.lacrampe.obeo.fr
Messages: 62
Registered: July 2018
Member
Hi Moe,

Yes you are right: you should use the Capella Requirements add-on to deal with Requirements in Capella, you can download and install it from here: https://polarsys.org/capella/download.html

There is a legacy data model for requirements in Capella but this will probably disappear, so you should use the add-on I mentioned to enter your requirements, you'll also be able to display your requirements in any Capella diagram with this add-on.

Once installed, I advise to read the embedded documentation that comes with the add-on so that you understand how it works, it is quite well written. Maybe this message will also guide you on the first steps with the add-on: https://polarsys.org/forums/index.php/mv/msg/628/2432/#msg_2 432

All the best,
Stéphane LACRAMPE
Obeo
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #2492 is a reply to message #2490] Thu, 25 October 2018 08:19 Go to previous messageGo to next message
moe.sadri is currently offline  moe.sadri
Messages: 7
Registered: July 2017
Junior Member
Thank you Stéphane for your help. I will use the new add-on then and follow the documentation.
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #2637 is a reply to message #2490] Wed, 12 December 2018 08:57 Go to previous messageGo to next message
gregoire.cassin.gmail.com is currently offline  gregoire.cassin.gmail.com
Messages: 5
Registered: May 2017
Junior Member
Hello,
I have well used the add-on requirement in my model and diagrams.
However, I do not succeed to make it appear in the HTML export. Is it normal?
I can see them on diagrams in HTML but I cannot click on Requirement neither have information or attributes related to them, in the HTML export.

Thank you in advance for your support.
Best regards,
Gregoire
Re: Addon Requirements v0.5.0 (beta) has been released for evaluation [message #2638 is a reply to message #2637] Wed, 12 December 2018 09:10 Go to previous message
Aurélien Pinsonneau is currently offline  Aurélien Pinsonneau
Messages: 169
Registered: November 2016
Senior Member
Hello Gregoire,

It is normal (yet unfortunate). HTML add-on allow an export of all the information related to Capella core meta-model with a predefined style based on the type of model element.
Requirement add-on defines an extension of Capella meta-model with its definition of Requirements.
In order to be exported in the html, an extension of the HTML add-on need to be developed in order to export the information related to this new kind of model element.

Unfortunately, this extension of the HTML add-on has not yet been developed...

In case of strong need from your side, a financial support could help fasten the availability of such extension!
Previous Topic: pxDoc v1.1.1 (document generation tool) has been released
Next Topic: Addon Requirements v0.9.0 has been released
Goto Forum:
  


Current Time: Sat Mar 28 03:57:26 EST 2020

Total time taken to generate the page: 0.02520 seconds