This service is archived, please use www.eclipse.org/forums


Home » Capella » General information » Addon Requirements v0.9.1 has been released
Addon Requirements v0.9.1 has been released [message #2224] Tue, 17 July 2018 08:27 Go to next message
grdevda.gmail.com is currently offline  grdevda.gmail.com
Messages: 6
Registered: April 2017
Junior Member
Addon Requirements v0.9.1 has been released

The Requirements Viewpoint for Capella allows importing a set of requirements from a ReqIF file.

You can download this official version on Capella website following this link

Compatibility: The recommended target Capella version is the upcoming minor release Capella 1.2.1
Release notes: link


(warning) This official Major Release 0.9 is not compatible with previous prototypes 0.5.x due to the fix of blocking issues (".melodymodeller.bridgetraces" file used for the iterative import has been modified in 0.9 to better persist ReqIf IDs, no migration provided for previous prototypes 0.5)

The next patch Doors patch 9.6.1.11 fixes the bug "APAR PI91749" links are missing in exports from baselines (see addon embedded doc in Eclipse / Help for more information)
Re: Addon Requirements v0.9.1 has been released [message #2227 is a reply to message #2224] Tue, 17 July 2018 15:25 Go to previous messageGo to next message
stephane.lacrampe.obeo.fr is currently offline  stephane.lacrampe.obeo.fr
Messages: 62
Registered: July 2018
Member
Hi,

I just wanted to mention that this version includes the ability to show allocated requirements in Capella diagrams as demonstrated in the last Capella webinar (https://www.youtube.com/watch?v=qFfj8K3uj3Y).

Also, the current download link on the Capella website still points to the 0.9.0 version. In the meantime, the 0.9.1 update site can be downloaded here: http://download.polarsys.org/capella/addons/requirements/upd ates/releases/org.polarsys.capella.vp.requirements-updateSit e-0.9.1.201807111332.zip

Stephane
Re: Addon Requirements v0.9.1 has been released [message #2673 is a reply to message #2227] Fri, 04 January 2019 12:06 Go to previous messageGo to next message
scott.millsap.cnxmotion.c is currently offline  scott.millsap.cnxmotion.c
Messages: 17
Registered: March 2018
Junior Member
With the release of Capella v1.3, any update on a compatible version of Requirements Viewpoint?
Re: Addon Requirements v0.9.1 has been released [message #2675 is a reply to message #2673] Mon, 07 January 2019 04:21 Go to previous messageGo to next message
Michel BISPO is currently offline  Michel BISPO
Messages: 33
Registered: February 2015
Member
Hi,
the version 0.10.0 compatible with Capella 1.3 will be delivered soon, before the end of this month.
Best regards,

Michel
Re: Addon Requirements v0.9.1 has been released [message #2690 is a reply to message #2675] Thu, 10 January 2019 09:39 Go to previous message
Michel BISPO is currently offline  Michel BISPO
Messages: 33
Registered: February 2015
Member
Hi,
the new version 0.10.0 for Capella 1.3 is available, see link "Requirements" at https://polarsys.org/capella/download.html#capellaExtensions
Best regards,
Michel
Previous Topic: Addon Requirements v0.10.0 has been released
Next Topic: Capella 1.2.2 has been released !
Goto Forum:
  


Current Time: Sun Mar 29 07:41:29 EST 2020

Total time taken to generate the page: 0.01645 seconds